...

Friday, November 5, 2010

CCNP BSCI 02

In this article I'm going to walk through the implementation of basic EIGRP. We will accomplish basic routing, default-route advertising and verification. This is the topology we'll be using:


R1 is connected to the networks 192.168.[0-7].0/24.

Unlike OSPF, EIGRP AS numbers are significant throughout the organization.

Assuming all IP addresses are configured, we'll begin configuration on R2. To start the EIGRP process, we'll use:
router eigrp 1

We'll begin adding networks with the "network" statement. There are many ways you can enter networks in EIGRP. You can fall back to the RIP style, or use the OSPF style. By default, EIGRP acts like a classful routing protocol. We'll first disable classful routing through:
no auto

Now, we'll add the two networks to the routing process of R2:
network 10.0.0.0

EIGPR automatically summarizes across discontiguous networks to their classful boundaries. The "no auto" disables that behavior as it would cause some problems.

The "no auto" command should be started before the network command because it would reset any existing neighbor relationships when you type that in.

We'll do the same on R3:
router eigrp 1
no auto
network 10.0.0.0


Now back on R1, we'll start the links and advertise the routes connected at the back-end. We'll make use of wildcard masks:
router eigrp 1
no auto
network 10.0.0.0
network 192.168.0.0 0.0.7.255


Network statements does not influence the prefix that is being advertised. It only affects which interfaces that EIGRP is active on. To enable EIGRP on all interface, you can use:
network 0.0.0.0 255.255.255.255

To see what neighbors a router has, use:
sh ip eigrp nei

EIGRP sends Hello messages every 5 seconds. The Hold Down timer is the time it takes for the neighbor to expire. EIGRP default Hold Down timer is 15 seconds.

To check the routes known to the EIGRP process, use:
show ip eigrp top

Now we'll advertise some default route information. We'll assume that R1 is connected to the internet. There are many ways to advertise a default gateway. One of the ways is the "ip default-network" command. If we type this on R1, it does nothing for it, but it tells R2 and R3 to route packets towards a particular network by default.

The other way to advertise a default route is to first create a static default route like this:
ip route 0.0.0.0 0.0.0.0 192.168.0.2

Then we can advertise the route through:
router eigrp 1
network 0.0.0.0


We can also redistribute the route through:
redistribute static

No comments :

Post a Comment

<