...

Monday, April 5, 2010

CCNA 45

The CCNA exam only tests on Single-area OSPF. However, we will try to go a bit into multi-area OSPF. First, we'll be using this topology:

All routes in the topology will belong to Area 0. On R3, 8 Loopback interfaces will be created to simulate an area 1. We'll first remove RIP on all routers:
no router rip

Now we'll create the Loopback interfaces on R3:
in lo0
ip add 172.16.0.1 255.255.255.0
no shut
in lo1
ip add 172.16.1.1 255.255.255.0
no shut
in lo2
ip add 172.16.2.1 255.255.255.0
no shut
in lo3
ip add 172.16.3.1 255.255.255.0
no shut
in lo4
ip add 172.16.4.1 255.255.255.0
no shut
in lo5
ip add 172.16.5.1 255.255.255.0
no shut
in lo6
ip add 172.16.6.1 255.255.255.0
no shut
in lo7
ip add 172.16.7.1 255.255.255.0
no shut


Back on R1, we'll now add F0/0 and F0/1 (including subinterfaces) into the routing process. To do this, type:
conf t
router ospf 1
network 192.169.0.0 0.0.255.255 area 0


In R2, you would have to add both F0/0 and S0/0 to the routing process. To do this, type:
network 192.169.1.0 0.0.3.255 area 0

Finally, in R3, you would have to add the S0/0 to area 0, and all loopbacks to area 1:
network 192.169.2.2 0.0.0.0 area 0
network 172.16.0.0 0.0.7.255 area 1


Now all routes should be propagated. Go back on R1 and advertise the default route:
default-information originate

Now back on R1, you should see a whole bunch of 172.16 routes. This is inefficient as mentioned before.
C    192.169.30.0/24 is directly connected, FastEthernet0/1.30
C    192.169.10.0/24 is directly connected, FastEthernet0/1.10
     172.16.0.0/32 is subnetted, 8 subnets
O IA    172.16.5.1 [110/66] via 192.169.1.2, 00:00:07, FastEthernet0/1.1
O IA    172.16.4.1 [110/66] via 192.169.1.2, 00:00:07, FastEthernet0/1.1
O IA    172.16.7.1 [110/66] via 192.169.1.2, 00:00:07, FastEthernet0/1.1
O IA    172.16.6.1 [110/66] via 192.169.1.2, 00:00:07, FastEthernet0/1.1
O IA    172.16.1.1 [110/66] via 192.169.1.2, 00:00:07, FastEthernet0/1.1
O IA    172.16.0.1 [110/66] via 192.169.1.2, 00:00:07, FastEthernet0/1.1
O IA    172.16.3.1 [110/66] via 192.169.1.2, 00:00:07, FastEthernet0/1.1
O IA    172.16.2.1 [110/66] via 192.169.1.2, 00:00:07, FastEthernet0/1.1
C    192.169.20.0/24 is directly connected, FastEthernet0/1.20
C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    192.169.1.0/24 is directly connected, FastEthernet0/1.1
O    192.169.2.0/24 [110/65] via 192.169.1.2, 00:00:08, FastEthernet0/1.1
S*   0.0.0.0/0 [1/0] via 192.168.1.1
We'll need to summarize this. To do this, go back on R3 and type:
area 1 range 172.16.0.0 255.255.248.0

Now we should have this summary:
C    192.169.30.0/24 is directly connected, FastEthernet0/1.30
C    192.169.10.0/24 is directly connected, FastEthernet0/1.10
     172.16.0.0/21 is subnetted, 1 subnets
O IA    172.16.0.0 [110/66] via 192.169.1.2, 00:00:04, FastEthernet0/1.1
C    192.169.20.0/24 is directly connected, FastEthernet0/1.20
C    192.168.1.0/24 is directly connected, FastEthernet0/0
C    192.169.1.0/24 is directly connected, FastEthernet0/1.1
O    192.169.2.0/24 [110/65] via 192.169.1.2, 00:01:41, FastEthernet0/1.1
S*   0.0.0.0/0 [1/0] via 192.168.1.1


Now suppose the before-mentioned scenario occurs and the network grows. A 172.16.8.0/24 gets added. Let's create a Loopback 8 on R3 that's in that network:
in lo8
ip add 172.16.8.1 255.255.255.0
no shut


The OSPF router ID is the name of the router. We can see the router's ID through:
show ip prot

To see your neighbor's router ID, use:
show ip ospf nei

The router ID takes the hard-coded router ID. If it's not entered, it then take the highest Loopback interface address. If there are no loopbacks, it would take the ID of the highest physical interface.

To hard-code the router ID, use:
router-id 1.1.1.1

After changing the router ID, you would have to restart the OSPF process:
clear ip ospf process
y


To troubleshoot neighbor problems, use:
debug ip ospf adj

No comments :

Post a Comment

<