...

Saturday, November 6, 2010

CCNP BSCI 08

It has always been a nightmare to think about OSPF implementation over the different Non-Broadcast Multi-Access (NBMA) networks.
In this world, there are three types of networks:
-Broadcast, Multi-Access Networks
Ethernet, Token Ring
Single Operation Mode
DR/BDR Election, 10 second Hellos, Dual Multicast Address

-Point-to-Point Networks
T1 CAS, ISDN BRI/PRI
Single Operation Mode
No DR/DR, 10 second Hellos, Single Multicast Address

-Non-Broadcast Multi-Access Networks
X.25, Frame Relay, ATM
Five Modes of Operation (Two are Industry Standard)

OSPF has 5 modes of operation over NBMA networks. It depends on what Frame Relay Topology you're going to use. Let's review the topologies:

The most costly but the one with the highest performance and redundancy is the Full Mesh network:


If you only keep the links between important sites meshed, you'd have a Partial Mesh network:


Finally, if you employ a star topology, you'd have a Hub and Spoke network and this is the most common because it's the cheapest to maintain but may have delay problems when it comes to VoIP:


Because there are so many ways you can connect your routers together, you have the flexibility (or complexity) of 5 Frame Relay modes:
-NBMA - RFC Standard
-Point-to-Multipoint - RFC Standard
-Point-to-Point - Cisco Proprietary
-Broadcast - Cisco Proprietary
-Point-to-Multipoint, Non-Broadcast - Cisco Proprietary

You cannot mix modes because they all use different timers.

NBMA mode is the default for X.25, Frame Relay and ATM. NBMA mode is also known as Non-Broadcast Mode. It means that no broadcast and no multicast messages are allowed over the cloud. The neighbors are statically configured and you have to use one subnet over the whole cloud. In Non-Broadcast mode, it is treated as a LAN environment (it assumes Full Mesh which you would need to fix with maps) and DR/BDR is elected and must be the hub.

In NBMA mode, it assumes that all broadcast and multicasts are denied, so you have to manually type in the neighbors. It will use unicast to reach the other routers. The place you define other routers is at the Hub of the network. For this to work properly, any router other than the Hub must have their priority set to 0:
ip ospf priority 0

To add neighbors in OSPF, simply type:
neighbor 10.0.0.2 priority 0

Now we'll implement basic OSPF over NBMA in the following topology:


First of all we're going to set up basic connectivity. To do this, we'll first go on R1 and set:
in s0/0
encap frame
ip add 10.0.0.1 255.255.255.0
frame map ip 10.0.0.2 102 broadcast
frame map ip 10.0.0.3 103 broadcast
no shut


Next, on R2, we'll set:
in s0/0
encap frame
ip add 10.0.0.2 255.255.255.0
frame map ip 10.0.0.1 201 broadcast
frame map ip 10.0.0.3 201 broadcast
ip ospf pri 0
no shut


Finally, R3 will have:
in s0/0
encap frame
ip add 10.0.0.3 255.255.255.0
frame map ip 10.0.0.1 301 broadcast
frame map ip 10.0.0.2 301 broadcast
ip ospf pri 0
no shut


(Much thanks to Candie for spotting the mapping mistake =p That was a bad copy and paste there!)

Notice that for R2 and R3, we have two entries pointing to the same DLCI. This is because NBMA mode assumes full mesh, so you'll need to have connectivity to each other and it's only through R1 that R2 can reach R3.

The broadcast keyword is present to make sure that all broadcast messages destined to that interface will be transmitted to the IP Address and DLCI as a unicast packet.

Now we'll begin setting up the network statements. Only R1 needs to put the neighbor statements:
network 10.0.0.1 0.0.0.0 area 0
neighbor 10.0.0.2 priority 0
neighbor 10.0.0.3 priority 0


For R2, it would be:
network 10.0.0.2 0.0.0.0 area 0

Finally, for R3, we'll have:
network 10.0.0.3 0.0.0.0 area 0

It will take an extremely long time for the neighbors to come up, so be patient! When you type the verification command "show ip ospf nei", it will be stuck at ATTEMPT for a minute or two.

The Point-to-Multipoint mode fixes issues with NBMA networks. In Point-to-Multipoint mode, there is no DR/BDR elected even though it still requires a single subnet. Neighbors automatically form without the need for static configuration. Broadcast and Multicast messages must be allowed across the Frame Relay cloud.

In Point-to-Multipoint mode, you don't have to specify overlapping DLCIs to go to each other. Instead, this would be the configuration of R2:
in s0/0
encap frame
ip add 10.0.0.2 255.255.255.0
frame map ip 10.0.0.1 201 broadcast
ip ospf network point-to-multipoint
no shut


For R3:
in s0/0
encap frame
ip add 10.0.0.3 255.255.255.0
frame map ip 10.0.0.1 301 broadcast
ip ospf network point-to-multipoint
no shut


The timers are still the same as NBMA so you can mix these.

Next, on R1, you would have:
in s0/0
encap frame
ip add 10.0.0.2 255.255.255.0
frame map ip 10.0.0.2 102 broadcast
frame map ip 10.0.0.3 103 broadcast
ip ospf network point-to-multipoint
no shut


You no longer need to specify neighbors, so R1 just needs one statement in the OSPF context:
network 10.0.0.1 0.0.0.0 area 0

Now, on R3, you would have these routes:
10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O       10.0.0.2/32 [110/128] via 10.0.0.1, 00:02:28, Serial0/0
C       10.0.3.0/24 is directly connected, Loopback0
O       10.0.2.1/32 [110/129] via 10.0.0.1, 00:02:28, Serial0/0
C       10.0.0.0/24 is directly connected, Serial0/0
O       10.0.0.1/32 [110/64] via 10.0.0.1, 00:02:28, Serial0/0


Notice that the routers are automatically discovered and advertised through the OSPF area. The next hop to get to R2 from R3 is now correctly recorded as R1! In a non-sub-interface environment, unless the ISP disallows broadcasts and multicasts, there is no reason why you should use NBMA over Point-to-Multipoint!

To configure Point-to-Multipoint Non-Broadcast mode, you simply have to use "ip ospf network point-to-multipoint non-broadcast". Neighbors will have to be statically specified.

Broadcast mode requires one subnet and full mesh connectivity. It treats the entire topology like a LAN. You would have a DR/BDR election and Multicast messages are used. It is exactly like the LAN environment. You set this with "ip ospf network broadcast".

The final and easiest (logically) mode to configure is the point-to-point mode. It makes the entire NBMA network act like a series of point-to-point links. Each DLCI gets its own sub-interface and requires one subnet each.

To configure this, we'll start on R1:
in s0/0
encap frame
no shut
in s0/0.102 point-to-p
frame interface-dlci 102
ip add 10.1.2.1 255.255.255.252
in s0/0.103 point-to-p
ip add 10.1.3.1 255.255.255.252
frame interface-dlci 103
router ospf 1
network 10.1.2.1 0.0.0.0 area 0
network 10.1.3.1 0.0.0.0 area 0


On R2, we have:
in s0/0
encap frame
no shut
in s0/0.201 point-to-p
frame interface-dlci 201
ip add 10.1.2.2 255.255.255.252
router ospf 1
network 10.1.2.2 0.0.0.0 area 0


Finally, R3 will have:
in s0/0
encap frame
no shut
in s0/0.301 point-to-p
frame interface-dlci 301
ip add 10.1.3.2 255.255.255.252
router ospf 1
network 10.1.3.2 0.0.0.0 area 0


This concludes the 5 modes of OSPF NBMA networks. You survived, really.

2 comments :

  1. very nicely explained. But in the NBMA (1st configuration) on R3; frame map to R3 address is there where as it should be frame map to R1's addres

    ReplyDelete
  2. Oh yes you're right! Good spotting there! Thanks a lot for the correction haha! This is what it should have been =p

    in s0/0
    encap frame
    ip add 10.0.0.3 255.255.255.0
    frame map ip 10.0.0.1 301 broadcast
    frame map ip 10.0.0.2 301 broadcast
    ip ospf pri 0
    no shut

    Once again, thank you :D

    ReplyDelete

<